Tags "docker" Result

Upgrade docker on CentOS 7

I'm running centos 7 and have installed docker on host using epel packages: yum install epel-release yum install docker But the docker version is-Docker version 0.11.1-dev, build 02d20af/0.11.1 The latest stable branch of docker is 1.2 I'm running couple of containers on this host, so how can i update docker safely on this host? yum update do

it1352 1 2019-05-15

Upgrade docker on CentOS 7

I'm running centos 7 and have installed docker on host using epel packages: yum install epel-release yum install docker But the docker version is-Docker version 0.11.1-dev, build 02d20af/0.11.1 The latest stable branch of docker is 1.2 I'm running couple of containers on this host, so how can i update docker safely on this host? yum update do

it1352 1 2019-05-13

Cannot connect to docker daemon

I have tried everything: add user, tried it with sudo but i didnt fix it. I tried it as a : sudo docker ps and docker ps Docker version : 1.11.2 OS/Archlinux gives an error : Cannot connect to the Docker daemon. Is the docker daemon running on this host? systemctl status docker : ● docker.service - Docker Application Container Engine Loaded: l

it1352 2 2019-05-15

What is the difference b/w "service docker start" and "docker -d"?

I'm new to docker, and want to restart docker daemon. I want to add the OPTS to start docker like: docker --registry-mirror=http://<my-docker-mirror-host> -d I want to know what is they difference? Does they start the same thing? By the way, I just use above command in my boot2docker, it did't work at all. Solution if you use service doc

it1352 0 2019-05-15

docker-compose.yml vs docker-stack.yml what difference?

I am new docker-user. And in difference manuals I have find usually docker-compose.yml file for description docker job, but on docker site for this goal used docker-stack.yml file. What difference? Solution docker-compose.yml is for the docker-compose tool which is for multi container docker applications on a single docker engine. its called with

it1352 1 2019-05-15

docker-engine conflicts with packages

I have installed docker-engine . Then i removed the package with apt-purge docker-engine command. so after it i see the following conflicts aptitude show docker-engine Package: docker-engine State: not installed Version: 1.8.3-0~trusty Priority: N/A Section: N/A Maintainer: Docker <support@docker.com> Architecture: amd64

it1352 0 2020-10-25