Tags "segmentation-fault" Result

A lot of SIGSEGV while strace'ing java process

Interesting stuff occurred while I debug one of the unit tests on CI server (maven build actually). I connect to java process with strace -ff -e trace=network -p [pid] to trace network activity of build process. And that's what I saw: Process 26324 attached Process 26325 attached (waiting for parent) Process 26325 resumed (parent 26312 ready) Proc

it1352 1 2019-05-22

Segmentation fault 11 when installing composer on OSX 10.9.2

I've been trying to install composer, but keeps getting error "Segmentation fault:11". Below is a list of what I have tried: sudo curl -sS https://getcomposer.org/installer | php Output: #!/usr/bin/env php All settings correct for using Composer Segmentation fault: 11 Reinstall command line tools Update homebrew Install php54 and compose

it1352 0 2020-08-12

Segmentation fault!

I have a wierd problem. In my main function I print "test" as the first thing. But if I run the call to node_alloc AFTER the printf call I get a segmentation fault and test is not printed! #include <stdlib.h> #include <stdio.h> typedef struct _node_t { int num_kids; void *content; struct _node_t **kids; // Makes a pointer t

it1352 3 2019-06-25

Segmentation fault

Possible Duplicate: Segmentation fault in btree implementation I am new to C coding and I am facing a problem. I get an error like this, how can I debug it? Can you please give some some method to debug this error: *** glibc detected *** ./a.out: free(): invalid pointer: 0x0821b158 *** ======= Backtrace: ========= /lib/tls/i68

it1352 1 2019-05-09

Segmentation Fault....

Hi I''m coding this simple program, but I get a segmentation fault, I''m pretty sure that the arrays are big enough and there isn''t really any buffer overflows so why is this happening? Program as followed: #include <stdio.h> #include <math.h> //------------------------------------------------------ // Programming II - Coursework As

it1352 3 2019-06-25

Segmentation Fault: 11 - Xcode 6.3

Can't archive My app runs fine (Xcode 6.3.2, swift based) on Simulator and on multiple devices. But when I try to archive it I get the error Command failed due to signal: Segmentation fault: 11. Others face same problem Segmentation Fault 11 when running Swift app "Command failed due to signal: Segmentation fault: 11" - What is the is

it1352 11 2019-05-14