Gradle keep on asking update and downgrade?

Question

I keep on getting "Gradle Sync error" so i checked had version 1.8. updated to 1.10, then it said i need 1.9, so i downgraded to 1.9 it said i need 1.8, when i downgrade to 1.8 it says i need 1.9.

15:28:09 Failed to refresh Gradle project 'Calendar'
         You are using Gradle version 1.8, which is not supported. Please use version 1.9.
         Please point to a supported Gradle version in the project's Gradle settings or in the project's Gradle wrapper (if applicable.)
         Fix Gradle wrapper and re-import project Gradle settings
15:28:26 Failed to refresh Gradle project 'Calendar'
         You are using Gradle version 1.10, which is not supported. Please use version 1.9.
         Please point to a supported Gradle version in the project's Gradle settings or in the project's Gradle wrapper (if applicable.)
         Fix Gradle wrapper and re-import project Gradle settings
15:28:39 Failed to refresh Gradle project 'Calendar'
         Gradle version 1.8 is required. Current version is 1.9. If using the gradle wrapper, try editing the distributionUrl in
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Android
Studio\gradle\wrapper\gradle-wrapper.properties to gradle-1.8-all.zip.
         Please fix the project's Gradle settings.
Solution

Gradle 1.10 is not yet supported in AS, Android Tools Developer team is working on it and probably will be available in next release.

As of now make sure all your build.gradle files in the project using gradle 1.9 as dependency

  buildscript {
      repositories {
        mavenCentral()
      }
  dependencies {
      classpath 'com.android.tools.build:gradle:0.7. '
     }
  }

Update :

Gradle 1.10 is now supported in Android studio after release 0.4.3, so going forward you can start using 1.10 plugin by using 0.8. in your classpath like this

classpath 'com.android.tools.build:gradle:0.8. '