Java "lambda expressions not supported at this language level"

Question

I was testing out some new features of Java 8 and copied the example into my IDE (Eclipse originally, then IntelliJ) as shown here: http://docs.oracle.com/javase/tutorial/java/javaOO/examples/RosterTest.java

Eclipse offered no support whatsoever for lambda expressions, and IntelliJ kept reporting an error "Lambda expressions not supported at this language level". I would like to know if this is a problem with my install, the code, or support.

Solution

In IntelliJ IDEA:

In File MenuProject StructureProject, change Project Language Level to 8.0 - Lambdas, type annotations etc.